RAM upgrade

I installed some extra memory in a PC this evening, which turned out to be a bit more interesting than I’d expected.

The initial status was that it had 128Mb of RAM. I had a 256Mb chip, which would increase it to 384Mb. Windows XP was running very slowly, so I figured that tripling the memory should help.

The machine turned out to have four chips in there already, so I figured that they were probably 32Mb each. I took one of them out, and replaced it with the 256Mb chip, and booted back up again. It now reported 224Mb altogether. Something’s not right there… It turns out that the existing chips were: 1 x 128Mb, 1 x 64Mb, 2 x 32Mb. Given this odd combination, I’m guessing that someone tried to upgrade it┬ápiecemeal in the past, rather than it arriving from the manufacturer like that. Admittedly the chips weren’t clearly labelled, so I had to go digging on the web for the serial numbers, but I think that kind of effort is worthwhile rather than just sticking them in and hoping for the best.

On closer inspection, I discovered that the 32Mb chips were only PC-66 rather than PC-100 (i.e. they run at 66Mhz rather than 100Mhz), so the motherboard didn’t support them, and they in fact seemed to be crippling the memory banks overall, effectively sabotaging other chips. So, I could have boosted the memory just by removing them, even without the new chip; this would have taken it from 128Mb to 192Mb. Anyway, the upshot of this is that the machine now has 448Mb of RAM, so it should run significantly faster now.

This is actually the first time I’ve encountered this problem, so it’s something to be careful of. It’s ok to use a higher speed, e.g. PC-133 chips in a PC-100 motherboard, although it’s a bit of a waste since the chips will still only run at 100Mhz, but you can’t get slower chips to run at a faster speed. (If you’re buying new memory, I strongly recommend Crucial – they’re a bit more expensive than some other companies, but they will tell you exactly what you need for your motherboard, and I’ve never had any of their chips failing on me.)